Note: The other languages of the website are Google-translated. Back to English
English English

Som de kleinste of laagste N-waarden op in Excel

In Excel kunnen we gemakkelijk een celbereik optellen met behulp van de SOM-functie. Soms moet u mogelijk de kleinste of onderste 3, 5 of n getallen in een gegevensbereik optellen, zoals hieronder wordt weergegeven. In dit geval kan de SOMPRODUCT samen met de SMALL-functie u helpen dit probleem in Excel op te lossen.


Som de kleinste of laagste N-waarden op met de functies SOMPRODUCT en SMALL

Om het kleinste n-getal in een gegevensbereik op te tellen, kunt u de kleinste n-getallen vinden met behulp van de SMALL-functie en vervolgens de SOMPRODUCT-functie toepassen om de arraylijst rechtstreeks op te tellen, de generieke syntaxis is:

=SUMPRODUCT(SMALL(range,{1,2,…,N}))
  • range: Het cellenbereik bevat de op te tellen getallen;
  • N: Vertegenwoordigt de N-de onderste waarde.

Hier zal ik de laagste 4 getallen in het bereik B2:B12 optellen, voer de onderstaande formule in of kopieer deze naar een lege cel en druk op Enter sleutel om het resultaat te krijgen:

=SUMPRODUCT(SMALL(B2:B12,{1,2,3,4}))


Verklaring van de formule:

=SOMPRODUCT(KLEIN(B2:B12,{1,2,3,4}))

  • KLEIN(B2:B12,{1,2,3,4}):Deze SMALL-functie wordt gebruikt om de 1e, 2e, 3e en 4e kleinste waarden in het bereik B2:B12 te retourneren, je krijgt de array als volgt: {200,230,345,560}.
  • SOMPRODUCT(KLEIN(B2:B12,{1,2,3,4}))=SOMPRODUCT({200,230,345,560}): De SOMPRODUCT-functie telt alle getallen in de arraylijst op om het resultaat te krijgen:1335.

Tips: Oplossing als N groot wordt:

Soms heb je een grote lijst met getallen, om het kleinste getal van 50 of meer in het bereik op te tellen, zal het vervelend zijn om het getal 1,2,3,4…50 in te voeren in de SMALL-functie. Dus hier kunt u de ROW- en INDIRECT-functies gebruiken om de arrayconstante te maken.

Als u bijvoorbeeld de laagste 10 waarden in een bereik wilt optellen, past u de onderstaande formules toe:

Handmatig een nummer invoeren:

=SUMPRODUCT(SMALL(B2:B15,ROW(INDIRECT("1:10"))))

Gebruik een celverwijzing:

=SUMPRODUCT(SMALL(B2:B15,ROW(INDIRECT("1:"&D2))))


Gebruikte relatieve functie:

  • SUMPRODUCT:
  • De SOMPRODUCT-functie kan worden gebruikt om twee of meer kolommen of arrays met elkaar te vermenigvuldigen en vervolgens de som van producten te krijgen.
  • SMALL:
  • De Excel SMALL-functie retourneert een numerieke waarde op basis van de positie in een lijst wanneer gesorteerd op waarde in oplopende volgorde.

Meer artikelen:

  • Som kleinste of laagste N-waarden op basis van criteria
  • In de vorige zelfstudie hebben we besproken hoe u de kleinste n-waarden in een gegevensbereik kunt optellen. In dit artikel zullen we een verdere geavanceerde bewerking uitvoeren - om de laagste n-waarden op te tellen op basis van een of meer criteria in Excel.
  • Som alle nummercellen op en negeer fouten
  • Bij het optellen van een reeks getallen die enkele foutwaarden bevatten, zal de normale SOM-functie niet correct werken. Om alleen getallen op te tellen en de foutwaarden over te slaan, kan de AGGREGATE-functie of de SOM samen met de IFERROR-functies u een plezier doen.

De beste tools voor kantoorproductiviteit

Kutools for Excel - Helpt u zich te onderscheiden van de menigte

Wilt u uw dagelijkse werkzaamheden snel en perfect afronden? Kutools voor Excel biedt 300 krachtige geavanceerde functies (werkmappen combineren, optellen op kleur, celinhoud splitsen, datum converteren, enzovoort ...) en 80% tijd voor u besparen.

  • Ontworpen voor 1500 werkscenario's, helpt u 80% Excel-problemen op te lossen.
  • Verminder elke dag duizenden toetsenbord- en muisklikken, verlicht uw vermoeide ogen en handen.
  • Word een Excel-expert in 3 minuten. U hoeft geen pijnlijke formules en VBA-codes meer te onthouden.
  • 30 dagen onbeperkte gratis proefperiode. 60 dagen geld-terug-garantie. Gratis upgrade en ondersteuning gedurende 2 jaar.
Lint van Excel (met Kutools voor Excel geïnstalleerd)

Office-tabblad - Schakel lezen en bewerken met tabbladen in Microsoft Office in (inclusief Excel)

  • Een seconde om te schakelen tussen tientallen geopende documenten!
  • Verminder elke dag honderden muisklikken voor u, zeg maar dag tegen muishand.
  • Verhoogt uw productiviteit met 50% bij het bekijken en bewerken van meerdere documenten.
  • Brengt efficiënte tabbladen naar Office (inclusief Excel), net als Chrome, Firefox en New Internet Explorer.
Schermopname van Excel (met Office-tabblad geïnstalleerd)
Comments (0)
Nog geen beoordelingen. Beoordeel als eerste!
Er zijn nog geen reacties geplaatst
Laat uw commentaar
Posten als gast
×
Beoordeel dit bericht:
0   Personages
Voorgestelde locaties