Ga naar hoofdinhoud

Excel-formule: Kwartaal vanaf datum ophalen

doc converteer datum naar julia 1

Soms wilt u misschien het kwartaalnummer uit een lijst met datums halen bij het maken van een jaarlijks financieel verslag. Deze zelfstudie biedt formules waarmee u een kwartaal kunt krijgen van bepaalde datums in Excel.

Als u deze tutorial wilt volgen, download dan de voorbeeldspreadsheet.
doc converteer datum naar julia 1

Generieke formule

ROUNDUP(MONTH(date)/3,0)

Syntaxis en argumenten

Date: the date that used to get the quarter from.

Winstwaarde

De formule retourneert een numerieke waarde.

fouten

Als de datum eerder is dan 1/1/1900, of als de datum geen numerieke waarde is, keert de formule terug naar een foutwaarde #WAARDE!

Hoe deze formule werkt

Het bereik B3: B8 geeft de datums weer. Gebruik nu de onderstaande formule om het kwartaal van deze datums in cel C3 te krijgen:

=ROUNDUP(MONTH(B3)/3,0)

Media Enter toets en sleep vervolgens de hand voor automatisch aanvullen naar de cel C8 om de kwartalen van andere datums te krijgen.
doc converteer datum naar julia 1

Uitleg

MAAND functie: krijgt de maand als geheel getal (1 tot 12) vanaf de datum.

Hier krijgt formule MAAND(B3) resultaat 1.

ROUNDUP-functie: rondt een getal naar boven af ​​op een bepaald aantal cijfers. Hier geeft 0 aan dat het getal naar boven moet worden afgerond op een geheel getal.

=AFRONDEN(MAAND(B3)/3,0)
=AFRONDEN (1/3,0)
=AFRONDEN(0.333,0)
=1

Verlenging

1. Als u het resultaat wilt krijgen zoals hieronder afgebeeld, kunt u de formule gebruiken zoals:

="Q"&ROUNDUP(MAAND(B3)/3,0)
doc converteer datum naar julia 1

2. Als u kwartaal en jaar vanaf de datum wilt krijgen, zoals hieronder afgebeeld, gebruik dan onderstaande screenshot:

="Q"&ROUNDUP(MAAND(B3)/3,0)&"-"&JAAR(B3)
doc converteer datum naar julia 1

JAAR, functie: krijgt het jaar als een 4-cijferig nummer op basis van de opgegeven datum.


Relatieve formules

Relatieve functies


De beste tools voor kantoorproductiviteit

Kutools for Excel - Helpt u zich te onderscheiden van de menigte

Populaire functies: Zoek, markeer of identificeer duplicaten  |  Verwijder lege rijen  |  Combineer kolommen of cellen zonder gegevens te verliezen  |  Ronde zonder formule ...
Super VLookup: Meerdere criteria  |  Meerdere waarde  |  Over meerdere vellen  |  Fuzzy opzoeken...
Gev. Keuzelijst: Gemakkelijke vervolgkeuzelijst  |  Afhankelijke vervolgkeuzelijst  |  Multi-select vervolgkeuzelijst...
Kolom Beheerder: Voeg een specifiek aantal kolommen toe  |  Kolommen verplaatsen  |  Schakel de zichtbaarheidsstatus van verborgen kolommen in  Vergelijk Kolommen met Selecteer dezelfde en verschillende cellen ...
Uitgelichte functies: Raster focus  |  Ontwerpweergave  |  Grote formulebalk  |  Werkmap- en bladbeheer | resource Library (Auto-tekst)  |  Datumkiezer  |  Combineer werkbladen  |  Cellen coderen/decoderen  |  Stuur e-mails per lijst  |  Super filter  |  Speciaal filter (filter vet/cursief/doorhalen...) ...
Top 15 gereedschapsets12 Tekst Tools (toe te voegen tekst, Tekens verwijderen ...)  |  50+ tabel Types (Gantt Chart ...)  |  40+ Praktisch Formules (Bereken leeftijd op basis van verjaardag ...)  |  19 Invoeging Tools (QR-code invoegen, Afbeelding invoegen vanaf pad ...)  |  12 Camper ombouw Tools (Getallen naar woorden, Currency Conversion ...)  |  7 Samenvoegen en splitsen Tools (Geavanceerd Combineer rijen, Excel-cellen splitsen ...)  |  ... en meer

Kutools voor Excel beschikt over meer dan 300 functies, Ervoor zorgen dat wat u nodig heeft slechts één klik verwijderd is...


Office-tabblad - Schakel lezen en bewerken met tabbladen in Microsoft Office in (inclusief Excel)

  • Een seconde om te schakelen tussen tientallen geopende documenten!
  • Verminder elke dag honderden muisklikken voor u, zeg maar dag tegen muishand.
  • Verhoogt uw productiviteit met 50% bij het bekijken en bewerken van meerdere documenten.
  • Brengt efficiënte tabbladen naar Office (inclusief Excel), net als Chrome, Edge en Firefox.
Comments (0)
No ratings yet. Be the first to rate!
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations