Note: The other languages of the website are Google-translated. Back to English

Hoe cellen met tekst te tellen in Excel

Excel is overal. Als een handig en krachtig hulpmiddel voor gegevensanalyse en documentatie, gebruiken we het vaak in werk en leven. In sommige gevallen moeten we onze gegevens mogelijk beter begrijpen om gegevensanalyse uit te voeren. In deze zelfstudie demonstreren we meerdere manieren om: tel cellen met tekst in Excel.

AANTAL.ALS/AANTAL.ALS-functie + Jokerteken om cellen met tekst in Excel te tellen

SOMPRODUCT + ISTEXT-functies om cellen met tekst in Excel te tellen

AANTAL.ALS-functie om cellen met specifieke tekst in Excel te tellen

Tel eenvoudig cellen die specifieke tekst bevatten met Kutools voor Excel


AANTAL.ALS/AANTAL.ALS-functie + Jokerteken om cellen met tekst in Excel te tellen

AANTAL.ALS-functie om cellen met elke tekst te tellen

Om cellen te tellen die tekst bevatten, gebruiken we het sterretje (*) in de AANTAL.ALS-formule. De syntaxis van de AANTAL.ALS-functie is als volgt:

=COUNTIF(range, "*")

Omdat de asterisk (*) een jokerteken is dat overeenkomt met elke reeks tekens, telt de formule alle cellen die tekst bevatten.

Bijvoorbeeld om te tellen cellen met tekst in het bereik A2:A15 zoals hieronder weergegeven, typt u de onderstaande formule in een lege cel en drukt u op de Enter knop om het resultaat te krijgen.

=AANTAL.ALS(A2:A15; "*")

cel tellen met tekst 1

√ Opmerkingen:
  • Wat wordt niet als tekst geteld:
  1. Cellen met tekst;
  2. Speciale tekens;
  3. Getallen opgemaakt als tekst;
  4. Visueel lege cellen die een lege tekenreeks (""), apostrof ('), spatie bevatten.
  • Wat wordt niet als tekst geteld:
  1. nummers;
  2. data;
  3. Logische waarden van True en False;
  4. fouten;
  5. Lege cellen.

In dit geval kunnen we duidelijk begrijpen waarom er 8 cellen met tekst in het voorbeeldwerkblad.

cel tellen met tekst 2

AANTAL.ALS-functie telt cellen zonder tekst

Als u cellen wilt tellen die geen tekst in een gegevensbereik bevatten, gebruikt u de niet gelijk aan de logische operator (<>) en sterretje (*) in de AANTAL.ALS-formule. De syntaxis is als volgt:

=COUNTIF(range, "<>*")

Omdat de niet gelijk aan de logische operator (<>) en het sterretje (*) betekent niet gelijk aan alle tekens, telt de formule de cellen zonder enige tekst.

Bijvoorbeeld voor tel cellen zonder tekst typ in het bereik A2:A15 de onderstaande formule in een lege cel en druk op de Enter knop om het resultaat te krijgen.

=AANTAL.ALS(A2:A15,"<>*")

cel tellen met tekst 3

Vervolgens krijgt u het aantal cellen dat niet-tekstwaarden bevat.

AANTAL.ALS-functie om cellen met tekst te tellen, exclusief visueel lege cellen

Als u cellen wilt tellen met tekst die visueel lege cellen uitsluit, gebruikt u het asterisk-symbool (*), het vraagteken (?) en de logische operator die niet gelijk is aan (<>) in de formule. De syntaxis is als volgt:

=COUNTIFS(range,"*?*", range, "<> ")

A vraagteken symbool (?) lucifers een enkel personage en een sterretje (*) lucifers elke reeks tekens. Een vraagteken omgeven door sterretjes (*?*) betekent dat er moet ten minste één teken in de cel staan, dus de lege tekenreeks en apostrof worden niet meegeteld.

Het niet gelijk aan symbool (<>) plus één lege spatie middel om de cellen met het spatieteken niet te tellen.

Als u bijvoorbeeld cellen met tekst wilt tellen zonder visueel lege cellen in het bereik A2:A15, typt u de onderstaande formule in een lege cel en drukt u op de Enter knop om het resultaat te krijgen.

=AANTALLEN.ALS(A2:A15,"*?*", A2:A15, "<> ")

cel tellen met tekst 4

Dan kunt u het aantal cellen krijgen dat alleen zichtbare tekst bevatten.

√ Opmerkingen:
  1. De AANTAL.ALS-functie ondersteunt meerdere voorwaarden. Om in het bovenstaande voorbeeld cellen met tekst te tellen en ook cellen uit te sluiten die slechts één spatie, lege tekenreeks en apostrof bevatten, waardoor de cellen er allemaal blanco uitzien.
  2. Als u cellen met tekst wilt tellen en geen cellen wilt tellen die slechts één spatie bevatten, wordt de syntaxis: = AANTAL.ALS(bereik,"*", bereik, "<> ").

SOMPRODUCT + ISTEXT-functies om cellen met tekst in Excel te tellen

De tweede manier om cellen met tekstwaarden te tellen, is door de SOMPRODUCT-functie tezamen met de ISTEXT-functie. De syntaxis is als volgt:

=SUMPRODUCT(--ISTEXT(range))
or
=SUMPRODUCT(ISTEXT(range)*1)

Het ISTEXT-functie Retourneren Waar of niet waar wanneer een cel tekst of niet-tekst bevat. En de dubbele ontkenning (--) in de eerste syntaxis en de vermenigvuldigingsoperatie in de tweede syntaxis zijn twee manieren om forceer WAAR en ONWAAR in de numerieke 1 en 0.

Dan SOMPRODUCT-functie Retourneren de som van alle enen en nullen in het zoekbereik en geeft een laatste telling.

Als u in dit geval cellen met tekst in het bereik A2:A15 wilt tellen, typt u de onderstaande formule in een lege cel en drukt u op de Enter knop om het resultaat te krijgen.

=SOMPRODUCT(--ISTEKST(A2:A15))

or

=SOMPRODUCT(ISTEKST(A2:A15)*1)

cel tellen met tekst 5

cel tellen met tekst 6

Welke syntaxis u ook gebruikt, het geretourneerde resultaat is: 8.

AANTAL.ALS-functie om cellen met specifieke tekst in Excel te tellen

Tel cellen die bepaalde tekst bevatten met een exacte overeenkomst

Om een exacte overeenkomst van de AANTAL.ALS-functie, voert u gewoon de volledige tekst in met aanhalingstekens in het tweede argument in de formule. Hier is de syntaxis:

=COUNTIF(range, "text value")

Om tekst in een formule in Excel toe te voegen, de tekst tussen aanhalingstekens plaatsen ("…") is noodzakelijk.

Als u bijvoorbeeld wilt weten hoeveel cellen in het bereik A2:A10 precies het woord "pen" of "potlood" bevatten, typt u de onderstaande formule in een lege cel en drukt u op de Enter knop om het resultaat te krijgen.

=AANTAL.ALS(A2:A10; "pen")

or

=AANTAL.ALS(A2:A10; "potlood")

cel tellen met tekst 7

cel tellen met tekst 8

Tel cellen die bepaalde tekst bevatten met een gedeeltelijke overeenkomst

Cellen tellen met a gedeeltelijke overeenkomst, plaatst u de tekst tussen twee sterretjes (*) en plaatst u ze tussen aanhalingstekens (“”). Dan staat AANTAL.ALS toe om tel alle cellen die de tekst bevatten en alles ervoor en erna. Hier is de syntaxis:

=COUNTIF(range, "*text value*")

Stel in dit geval dat u wilt tellen hoeveel cellen "pen" of "potlood" bevatten als onderdeel van hun inhoud op een willekeurige positie, typt u de onderstaande formule in een lege cel en drukt u op de Enter knop om het resultaat te krijgen.

=AANTAL.ALS(A2:A10; "*pen*")

or

=AANTAL.ALS(A2:A10; "*potlood*")

cel tellen met tekst 9

cel tellen met tekst 10

√ Opmerkingen: AANTAL.ALS is niet hoofdlettergevoelig.

Tel eenvoudig cellen die specifieke tekst bevatten met Kutools voor Excel

Naast het gebruik van een formule om de cellen met tekst te tellen, kunt u de Selecteer specifieke cellen nut van Kutools for Excel om snel de cellen met specifieke tekst in Excel te tellen en te selecteren.

Het maakt niet uit of je cellen wilt tellen die bepaalde tekst bevatten met een exacte overeenkomst of met een gedeeltelijke overeenkomst, onze Kutools voor Excel kan u helpen uw doel gemakkelijk te bereiken.

Kutools for Excel : met meer dan 300 handige Excel-invoegtoepassingen, gratis te proberen zonder beperking in 30 dagen.

Na gratis installeren Kutools for Excel, laten we eens kijken hoe het werkt!

Tel en selecteer cellen die exact overeenkomen met specifieke tekst met Kutools

In dit geval wilt u weten hoeveel cellen in het bereik A2:A10 precies de tekst "pen" bevatten.

cel tellen met tekst 11

1. Selecteer het bereik waarvan u de cellen wilt tellen die specifieke tekst bevatten.

2. klikken Kutools > kies > Selecteer specifieke cellen.

cel tellen met tekst 12

3. In de Dialoogvenster Specifieke cellen selecteren, je moet:

  • kies cel optie functie in het Selectie type sectie;
  • Selecteer in het gedeelte Specifiek type Is gelijk aan typ in de vervolgkeuzelijst pen in het tekstvak;
  • Klik op de OK knop. Dan een prompt box verschijnt om u te vertellen hoeveel cellen overeenkomen met de voorwaarde.

cel tellen met tekst 13

  • Klik op de OK knop in het promptvenster en alle gekwalificeerde cellen worden tegelijkertijd in Excel geselecteerd.

cel tellen met tekst 14

Tel en selecteer cellen die gedeeltelijk overeenkomen met specifieke tekst met Kutools

Stel dat u wilt tellen hoeveel cellen in het bereik A2:A10 het woord "pen" bevatten als onderdeel van de inhoud op een willekeurige positie. De truc is vergelijkbaar met de laatste.

1. Selecteer het bereik waarvan u het aantal cellen wilt tellen dat specifieke tekst bevat.

2. klikken Kutools > kies > Selecteer specifieke cellen.

cel tellen met tekst 12

3. In de Dialoogvenster Specifieke cellen selecteren, je moet:

  • kies cel optie functie in het Selectie type sectie;
  • Selecteer in het gedeelte Specifiek type Bevat in de vervolgkeuzelijst, voer pen in in het tekstvak;
  • Klik op de OK knop. Dan een prompt box verschijnt om u te vertellen hoeveel cellen overeenkomen met de voorwaarde.

cel tellen met tekst 15

  • Klik op de OK knop in het promptvenster en alle gekwalificeerde cellen worden tegelijkertijd in Excel geselecteerd.

cel tellen met tekst 16

Klik om Kutools voor Excel te downloaden voor een gratis proefperiode van 30 dagen.



  • Super Formula-balk (bewerk eenvoudig meerdere regels tekst en formule); Lay-out lezen (gemakkelijk grote aantallen cellen lezen en bewerken); Plakken in gefilterd bereik...
  • Voeg cellen / rijen / kolommen samen en het bewaren van gegevens; Gespleten cellen inhoud; Combineer dubbele rijen en som / gemiddelde... Voorkom dubbele cellen; Vergelijk Ranges...
  • Selecteer Dupliceren of Uniek Rijen; Selecteer lege rijen (alle cellen zijn leeg); Super zoeken en fuzzy zoeken in veel werkboeken; Willekeurige selectie ...
  • Exacte kopie Meerdere cellen zonder de formuleverwijzing te wijzigen; Maak automatisch verwijzingen naar meerdere bladen; Plaats kogels, Selectievakjes en meer ...
  • Favoriete formules en snel invoegen, Bereiken, grafieken en afbeeldingen; Versleutel cellen met wachtwoord; Maak een mailinglijst en stuur e-mails ...
  • Extraheer tekst, Tekst toevoegen, Verwijderen op positie, Ruimte verwijderen; Paging-subtotalen maken en afdrukken; Converteren tussen celinhoud en opmerkingen...
  • Super filter (bewaar en pas filterschema's toe op andere bladen); Geavanceerd sorteren per maand / week / dag, frequentie en meer; Speciaal filter door vet, cursief ...
  • Combineer werkmappen en werkbladen; Tabellen samenvoegen op basis van sleutelkolommen; Gegevens splitsen in meerdere bladen; Batch Converteer xls, xlsx en PDF...
  • Draaitabel groeperen op weeknummer, dag van de week en meer ... Toon ontgrendelde, vergrendelde cellen door verschillende kleuren; Markeer cellen met formule / naam...
kte tabblad 201905
  • Schakel bewerken en lezen met tabbladen in Word, Excel, PowerPoint in, Publisher, Access, Visio en Project.
  • Open en maak meerdere documenten in nieuwe tabbladen van hetzelfde venster in plaats van in nieuwe vensters.
  • Verhoogt uw productiviteit met 50% en vermindert elke dag honderden muisklikken!
officetab onderkant
Comments (0)
Nog geen beoordelingen. Beoordeel als eerste!
Er zijn nog geen reacties geplaatst
Laat uw commentaar
Posten als gast
×
Beoordeel dit bericht:
0  Personages
Voorgestelde locaties