Note: The other languages of the website are Google-translated. Back to English
Inloggen  \/ 
x
or
x
Registreer  \/ 
x

or

EXCEL AANTAL.ALS-functie - Tel cellen die niet leeg zijn, groter/kleiner zijn dan of een specifieke waarde bevatten

Wanneer u aan een Excel-werkblad werkt, kan het tellen van het aantal cellen, zoals het tellen van lege of niet-lege cellen, cellen groter dan of kleiner dan een bepaalde waarde, of cellen die een specifieke tekst bevatten, enkele veelvoorkomende taken zijn voor de meeste van ons. Om met deze berekeningen om te gaan, kan de COUNIT-functie in Excel u een plezier doen.

Syntaxis van AANTAL.ALS-functie in Excel

AANTAL.ALS-functie voor lege of niet-lege cellen

AANTAL.ALS-functie voor cellen kleiner dan, groter dan of gelijk aan een specifieke waarde

AANTAL.ALS-functie voor cellen die een specifieke waarde bevatten


Syntaxis van AANTAL.ALS-functie in Excel

Als een van de statistische functies in Excel telt AANTAL.ALS cellen die voldoen aan bepaalde criteria in een bepaald bereik. De syntaxis van de AANTAL.ALS-functie is:

=COUNTIF(range, criteria)

De syntaxis bevat twee argumenten: reeks en criteria:

  • reeks: verwijst naar het cellenbereik dat u wilt tellen.
  • criteria: verwijst naar de voorwaarde die u wilt gebruiken om cellen te tellen. U kunt bijvoorbeeld '>=80' als criterium gebruiken om te zoeken naar cellen met waarden die groter zijn dan of gelijk zijn aan 80 in het bereik dat u hebt geselecteerd.

Om de functie in Excel toe te passen, typt u = AANTAL.ALS (bereik, criteria) in een bestemmingscel. Bijvoorbeeld, =AANTAL.ALS(A1:B8,">=80").

De AANTAL.ALS-functie retourneert een numerieke waarde - het aantal cellen dat u wilde tellen.

Nu we een beter begrip hebben van de AANTAL.ALS-functie, gaan we verder met enkele echte voorbeelden.


AANTAL.ALS-functie voor lege of niet-lege cellen

Ik heb bijvoorbeeld een lijst met cellen die verschillende gegevenstypen bevatten, zoals tekst, Booleaanse waarden (TRUE en FALSE), getallen, datums en fouten. Is er een universele AANTAL.ALS-formule om alleen lege of niet-lege cellen te tellen, ongeacht de gegevenstypen in uw opgegeven bereik?

countif blanco minder 1

Tel lege cellen met de AANTAL.ALS-functie

Laat me nu de AANTAL.ALS-formule aan u voorstellen. Met de formule, ongeacht hoeveel gegevenstypen er in het bereik zijn, zal het u het exacte en juiste aantal lege cellen vertellen:

=COUNTIF(range,"")
Opmerking: er staat geen tekst tussen aanhalingstekens, wat betekent dat de cellen die u wilt tellen leeg zijn.

Om de AANTAL.ALS-functie te gebruiken om lege cellen te tellen, typt u de formule: =AANTAL.ALS(A1:A9,"") in een bestemmingscel en druk vervolgens op ENTER:

countif blanco minder 2 >>> countif blanco minder 3

In Excel is er ook een functie genaamd COUNTBLANK, die het aantal lege cellen in een opgegeven bereik retourneert. De syntaxis ervan is = COUNTBLANK (bereik). Voor het bovenstaande voorbeeld kunt u de formule gebruiken: =AANTALLEGE (A1:A9).


Tel niet-lege cellen met de AANTAL.ALS-functie

Om de cellen te tellen die niet leeg zijn, wil ik u hier de formule laten zien:

=COUNTIF(range,"<>")
Opmerking: <> in Excel betekent: niet gelijk aan. Dus de bovenstaande formule telt alle cellen die niet gelijk zijn aan blanco, of we kunnen zeggen, zijn niet blanco.

Om de AANTAL.ALS-functie te gebruiken om de cellen te tellen die niet leeg zijn, typt u de formule =AANTAL.ALS(A1:A9,"<>") in een bestemmingscel en druk vervolgens op ENTER:

countif blanco minder 4 >>> countif blanco minder 5

In Excel is er ook een functie genaamd COUNTA, die het aantal cellen retourneert dat waarden in een opgegeven bereik bevat. De syntaxis ervan is =COUNTA(bereik). Voor het bovenstaande voorbeeld kunt u de formule gebruiken: = AANTALARG (A1: A9).

Als u echter alleen cellen met alleen tekst wilt tellen en Booleaanse waarden (TRUE en FALSE), getallen, datums of fouten wilt uitsluiten, gebruik dan de onderstaande formule:

=COUNTIF(A1:A9,"*")
Note: A single asterisk (*) matches only the value in a text form.

countif blanco minder 6 >>> countif blanco minder 7

Tel niet-lege cellen met twee klikken

Als je have Kutools for Excel geïnstalleerd in uw Excel, met zijn Selecteer niet-lege cellen functie, kunt u alle niet-lege cellen tegelijk selecteren en het nummer krijgen zoals u nodig hebt.

1. Je kunt naar de Kutools tabblad in Excel, zoek kiesen klik Selecteer niet-lege cellen op de vervolgkeuzelijst. Zie screenshot:

countif blanco minder 8

2. Alle niet-lege cellen worden geselecteerd en er verschijnt een promptvenster om u het aantal niet-lege cellen te vertellen, zoals hieronder afgebeeld:

countif blanco minder 9

Klik om Kutools voor Excel te downloaden voor een gratis proefperiode van 30 dagen.


AANTAL.ALS-functie voor cellen kleiner dan, groter dan of gelijk aan een specifieke waarde

Hier hebben we twee hoofdmethoden voor u opgesomd om cellen te tellen met waarden die kleiner zijn dan, groter dan, gelijk aan of niet gelijk aan een specifieke waarde in Excel.

AANTAL.ALS kleiner dan, groter dan, gelijk aan of niet gelijk aan met formules

Als u een formule wilt gebruiken om cellen te tellen met waarden die kleiner zijn dan, groter dan, gelijk aan of niet gelijk aan een specifieke waarde, moet u goed gebruik maken van Vergelijkingsoperatoren (<, >, =, ).

Opmerking: De methode kan ook worden gebruikt om cellen te tellen met datums die vóór (kleiner dan <), na (groter dan >) of gelijk zijn aan (=) de datum die u opgeeft.

Laten we nu eens kijken naar enkele echte voorbeelden volgens de onderstaande tabel:

countif blanco minder 10

Om het aantal studenten te tellen waarvan de totale score is voorbij (>) 140, gebruik de formule:
=AANTAL.ALS(E2:E8,">140") >>> Het resultaat is 5
Om het aantal studenten te tellen wiens wiskundescore is lager dan (<) de score van Coco (de waarde in de cel D3), gebruik de formule:
=AANTAL.ALS(D2:D8,"<"&D3) >>> Het resultaat is 2
Opmerking: om een ​​celverwijzing in de AANTAL.ALS-functie te gebruiken met vergelijkingsoperatoren, moet u de operatoren tussen aanhalingstekens plaatsen en een ampersand (&) vóór de celverwijzing toevoegen.
Om het aantal studenten te tellen wiens Engelse score is groter dan of gelijk aan (≥) de score van Eddie (de waarde in cel C4), gebruik de formule:
=COUNTIF(C2:C8,">="&C4)-1 >>> The result is 5
Opmerking: de reden om 1 af te trekken is dat de criteria C2:C8,">="&C4 vraag AANTAL.ALS om alle overeenkomende cellen te tellen, inclusief die met Eddie's Engelse score, dus we moeten het van de formule aftrekken. Als je Eddie moet tellen, verwijder dan "-1” uit de formule.
Om het aantal studenten te tellen dat: zijn van (=) India, gebruik de formule:
=AANTAL.ALS(B2:B8,"India") OR =AANTAL.ALS(B2:B8,B2) >>> Het resultaat is 3
Opmerking: de waarde in de celverwijzing B2 is India, dus "India" en B2 zijn beide ok om hier als criteria te werken. In de AANTAL.ALS-functie zijn de criteria: niet hoofdlettergevoelig. De string "India" en "INDIA" zullen dus geen verschil maken voor het resultaat van de formule.
Om het aantal studenten te tellen dat: komen niet uit (≠) India, gebruik de formule:
=AANTAL.ALS(B2:B8,"<>India") OR =AANTAL.ALS(B2:B8,"<>"&B2) >>> Het resultaat is 4

De AANTAL.ALS-functie werkt alleen als er één voorwaarde is, voor de situatie met meer voorwaarden moet u de AANTAL.ALS-functie gebruiken. Om bijvoorbeeld het aantal studenten te tellen met een Engelse score tussen 60 en 90 (>60, <90), gebruikt u de formule: =COUNTIFS(B2:B8,">60",B2:B8,"<90").
Klik om meer te weten over de AANTAL.ALS-functie...


AANTAL.ALS kleiner dan, groter dan, gelijk aan of niet gelijk aan met een paar klikken

Om cellen te tellen met waarden die kleiner zijn dan, groter dan, gelijk aan of niet gelijk aan een specifieke waarde op een handiger manier, kunt u de Selecteer specifieke cellen functie uitf Kutools for Excel.

Voer na het installeren van Kutools voor Excel de volgende stappen uit:

1. Zoek de Kutools tabblad, ga dan naar kiesen klik Selecteer specifieke cellen in de vervolgkeuzelijst.

countif blanco minder 11

2. U ziet nu een pop-upvenster, ga als volgt te werk:

countif blanco minder 11

Hieronder is een voorbeeld om het aantal leerlingen te tellen met een wiskundescore: lager dan (<) de score van Coco met Kutools.

countif blanco minder 11

Opmerking: het programma retourneert het telresultaat en selecteert de cel(len) die aan uw criteria voldoen. Je kunt ze kopiëren als je dat nodig hebt.

Klik om Kutools voor Excel te downloaden voor een gratis proefperiode van 30 dagen.


AANTAL.ALS-functie voor cellen die een specifieke waarde bevatten

Om AANTAL.ALS te gebruiken om de cellen te tellen die een specifieke waarde bevatten (bijvoorbeeld de cellen met een letter Y), of zelfs om de cellen te tellen met een specifieke waarde op een bepaalde positie (bijvoorbeeld de cellen beginnen met een letter Y), we moet weten over de jokertekens.

Er zijn drie jokertekens - asterisk (*), vraag Mark (?), En tilde (~) beschikbaar in Excel voor de AANTAL.ALS-functie:

Asterisk (*) - Komt overeen met een willekeurig aantal tekens. *ijs kan bijvoorbeeld aardig, service, ijs, @#$ijs, enz. betekenen.
Vraagteken (?) - Komt overeen met een willekeurig teken. Bijvoorbeeld ma?? kan meer betekenen, maan, mo&%, moaa, enz.
tilde (~) - Komt overeen met het werkelijke jokerteken. ~* betekent bijvoorbeeld een letterlijk sterretje, ~~ betekent een letterlijke tilde.

Opmerking: Booleaanse waarden (TRUE en FALSE), getallen, datums en fouten worden niet als tekens geteld. Dus als er bovenstaande elementen in het door u geselecteerde celbereik zijn, moet u deze naar tekst converteren.

Meer informatie:
Hoe nummer naar tekst in Excel te wijzigen of om te zetten?
Hoe datum naar cijferreeks of tekstformaat in Excel te converteren?
Hoe # Formulefouten vervangen door 0, lege of bepaalde tekst in Excel?
Hoe Booleaans waar/onwaar naar getal (1/0) of tekst in Excel te converteren?


Tel cellen die specifieke woorden of tekens bevatten met de AANTAL.ALS-functie

Omdat we de jokertekens al kennen, is het tijd voor ons om te leren hoe we een AANTAL.ALS-formule kunnen gebruiken om de cellen te tellen die een specifiek teken of een bepaald woord of bepaalde woorden bevatten. Laten we de onderstaande voorbeelden bekijken:

countif blanco minder 1

Gebruik de formule om het aantal jongens in de klas te tellen:
=AANTAL.ALS(B2:B9,"MANNELIJK") >>> Het resultaat is 5
Gebruik de formule om het aantal namen te tellen dat de tekens "jeff" bevat (de waarde in cel A6):
=AANTAL.ALS(A2:A9,"*jeff*") OR = AANTAL.ALS (A2: A9; "*" & A6 & "*") >>> Het resultaat is 2
Gebruik de formule om het aantal namen te tellen dat de letter "e" bevat:
=COUNTIF(A2:A9,"*e*") >>> The result is 5
Gebruik de formule om het aantal namen te tellen dat de letter "e" niet bevat:
=AANTAL.ALS(A2:A9,"<>*e*") >>> Het resultaat is 3
Gebruik de formule om het aantal namen te tellen dat met de letter "e" begint:
=AANTAL.ALS(A2:A9,"e*") >>> Het resultaat is 2
Gebruik de formule om het aantal namen te tellen dat op de letter "e" eindigt:
=AANTAL.ALS(A2:A9,"*e") >>> Het resultaat is 1
Gebruik de formule om het aantal namen te tellen met de letter "m" als het derde teken:
=AANTAL.ALS(A2:A9,"??m*") >>> Het resultaat is 2

Tel cellen met specifieke woorden of tekens met een paar klikken

Met our Excel-invoegtoepassing insta.u.b. als volgt te werk gaan:

1. Naar de Kutools tabblad zoeken kiesen klik Selecteer specifieke cellen in de vervolgkeuzelijst.

countif blanco minder 1

2. In de Selecteer specifieke cellen dialoogvenster, selecteer het celbereik dat u wilt tellen en klik vervolgens op Cel onder de Selectie type, kies een voorwaarde in de vervolgkeuzelijst van de Specifiek type volgens uw behoeften.

countif blanco minder 1

Hier zal ik je twee voorbeelden geven gebruiken Kutools te counselent de cellen die het/de specifieke woord(en) of teken(s) bevatten.

• Om het aantal jongens in de klas te tellen, klik op Is gelijk aan in de vervolgkeuzelijst en typ Mannelijk frezen in het rechter invoervak, of u kunt een cel selecteren met de waarde "Man" in het werkblad door te klikken op countif blanco minder 1knop.

countif blanco minder 1

Het programma retourneert het telresultaat en selecteert de cel(len) die aan uw criteria voldoen. Je kunt ze kopiëren als je dat nodig hebt.

• Om het aantal namen te tellen dat de tekens “jeff” bevat, klikt u op Bevat in de vervolgkeuzelijst en typ jeff, of u kunt de cel A6 in het werkblad selecteren door te klikken op countif blanco minder 1knop.

countif blanco minder 1

Het programma retourneert het telresultaat en selecteert de cel(len) die aan uw criteria voldoen. Je kunt ze kopiëren als je dat nodig hebt.



  • Super Formula-balk (bewerk eenvoudig meerdere regels tekst en formule); Lay-out lezen (gemakkelijk grote aantallen cellen lezen en bewerken); Plakken in gefilterd bereik...
  • Voeg cellen / rijen / kolommen samen en het bewaren van gegevens; Gespleten cellen inhoud; Combineer dubbele rijen en som / gemiddelde... Voorkom dubbele cellen; Vergelijk Ranges...
  • Selecteer Dupliceren of Uniek Rijen; Selecteer lege rijen (alle cellen zijn leeg); Super zoeken en fuzzy zoeken in veel werkboeken; Willekeurige selectie ...
  • Exacte kopie Meerdere cellen zonder de formuleverwijzing te wijzigen; Maak automatisch verwijzingen naar meerdere bladen; Plaats kogels, Selectievakjes en meer ...
  • Favoriete formules en snel invoegen, Bereiken, grafieken en afbeeldingen; Versleutel cellen met wachtwoord; Maak een mailinglijst en stuur e-mails ...
  • Extraheer tekst, Tekst toevoegen, Verwijderen op positie, Ruimte verwijderen; Paging-subtotalen maken en afdrukken; Converteren tussen celinhoud en opmerkingen...
  • Super filter (bewaar en pas filterschema's toe op andere bladen); Geavanceerd sorteren per maand / week / dag, frequentie en meer; Speciaal filter door vet, cursief ...
  • Combineer werkmappen en werkbladen; Tabellen samenvoegen op basis van sleutelkolommen; Gegevens splitsen in meerdere bladen; Batch Converteer xls, xlsx en PDF...
  • Draaitabel groeperen op weeknummer, dag van de week en meer ... Toon ontgrendelde, vergrendelde cellen door verschillende kleuren; Markeer cellen met formule / naam...
kte tabblad 201905
  • Schakel bewerken en lezen met tabbladen in Word, Excel, PowerPoint in, Publisher, Access, Visio en Project.
  • Open en maak meerdere documenten in nieuwe tabbladen van hetzelfde venster in plaats van in nieuwe vensters.
  • Verhoogt uw productiviteit met 50% en vermindert elke dag honderden muisklikken voor u!
officetab onderkant
Say something here...
symbols left.
You are guest
or post as a guest, but your post won't be published automatically.
Loading comment... The comment will be refreshed after 00:00.

Be the first to comment.