Note: The other languages of the website are Google-translated. Back to English

Hoe vind ik waarde in een cel met een door komma's gescheiden lijst in Excel?

Stel dat een kolom door komma's gescheiden waarden bevat zoals Sales, 123, AAA, en nu wilt u weten of waarde 123 in de door komma's gescheiden cel staat, hoe kunt u dat dan doen? Dit artikel introduceert een methode om het probleem op te lossen.

Vind waarde in een cel met een door komma's gescheiden lijst met formule


Vind waarde in een cel met een door komma's gescheiden lijst met formule


De volgende formule kan u helpen bij het vinden van waarde in een cel met een door komma's gescheiden lijst in Excel. Ga als volgt te werk.

1. Selecteer een lege cel, voer de formule in =IF(ISNUMBER(SEARCH(123,A2)),"yes","no") in de formulebalk en druk vervolgens op Enter. Zie screenshot:

Opmerking:: in de formule is A2 dat de cel de door komma's gescheiden waarden bevat die u zult vinden.

2. Blijf de resultaatcel selecteren en sleep de vulhendel naar beneden om alle resultaten te krijgen. Als de waarde "123" in de door komma's gescheiden cellen staat, krijgt u het resultaat als "Ja"; anders krijgt u het resultaat als "Nee". Zie screenshot:


Gerelateerde artikelen:


De beste tools voor kantoorproductiviteit

Kutools voor Excel lost de meeste van uw problemen op en verhoogt uw productiviteit met 80%

  • visfuik: Snel invoegen complexe formules, grafieken en alles wat je eerder hebt gebruikt; Versleutel cellen met wachtwoord; Maak een mailinglijst en stuur e-mails ...
  • Super Formula-balk (bewerk eenvoudig meerdere regels tekst en formule); Lay-out lezen (gemakkelijk grote aantallen cellen lezen en bewerken); Plakken in gefilterd bereik...
  • Voeg cellen / rijen / kolommen samen zonder gegevens te verliezen; Gespleten cellen inhoud; Combineer dubbele rijen / kolommen... Voorkom dubbele cellen; Vergelijk Ranges...
  • Selecteer Dupliceren of Uniek Rijen; Selecteer lege rijen (alle cellen zijn leeg); Super zoeken en fuzzy zoeken in veel werkboeken; Willekeurige selectie ...
  • Exacte kopie Meerdere cellen zonder de formuleverwijzing te wijzigen; Maak automatisch verwijzingen naar meerdere bladen; Plaats kogels, Selectievakjes en meer ...
  • Extraheer tekst, Tekst toevoegen, Verwijderen op positie, Ruimte verwijderen; Paging-subtotalen maken en afdrukken; Converteren tussen celinhoud en opmerkingen...
  • Super filter (bewaar en pas filterschema's toe op andere bladen); Geavanceerd sorteren per maand / week / dag, frequentie en meer; Speciaal filter door vet, cursief ...
  • Combineer werkmappen en werkbladen; Tabellen samenvoegen op basis van sleutelkolommen; Gegevens splitsen in meerdere bladen; Batch Converteer xls, xlsx en PDF...
  • Meer dan 300 krachtige functies. Ondersteunt Office / Excel 2007-2019 en 365. Ondersteunt alle talen. Eenvoudig te implementeren in uw onderneming of organisatie. Gratis proefperiode van 30 dagen met volledige functies. 60 dagen geld-terug-garantie.
kte tabblad 201905

Office-tabblad Brengt een interface met tabbladen naar Office en maakt uw werk veel gemakkelijker

  • Schakel bewerken en lezen met tabbladen in Word, Excel, PowerPoint in, Publisher, Access, Visio en Project.
  • Open en maak meerdere documenten in nieuwe tabbladen van hetzelfde venster in plaats van in nieuwe vensters.
  • Verhoogt uw productiviteit met 50% en vermindert elke dag honderden muisklikken!
officetab onderkant
Comments (9)
Nog geen beoordelingen. Beoordeel als eerste!
Deze opmerking is gemaakt door de moderator op de site
Goedemorgen allemaal. Ik heb een Excel-vraag over het tellen van door komma's gescheiden specifieke waarden in een enkele cel in Excel. Ik wil geen 15's tellen in een enkele cel die 15,215,15,155,45,1515,15 bevat. Ik heb de resultaat 3. Is er een formule in Excel.
Deze opmerking is gemaakt door de moderator op de site
Ja, er is een functie in Excel die dit voor je kan doen. Zoals uitgelegd in het bovenstaande probleem om een ​​betere nauwkeurigheid van uw gegevens te krijgen, voegt u een komma toe aan de linker- en rechterkant van uw lijst en neemt u deze op in uw zoekopdracht. Zie voorbeeld hieronder:
, 15,215,15,155,45,1515,15,
=AANTAL.ALS(A1, ",15,"")
De uitleg van deze formule is als volgt: =AANTAL.ALS(celnummer of bereik, waarde waarnaar u zoekt/telt)
Laat het me weten als je een beter voorbeeld nodig hebt.
Deze opmerking is gemaakt door de moderator op de site
Hallo!
Dit is echt een coole formule, maar het heeft ... een fout? ... dat ik niet weet hoe ik er omheen moet werken. "Flaw" is niet het juiste woord, maar ik kan (het is maandag 8 uur) niet het juiste woord bedenken.
Wanneer u een deel van een nummer zoekt, krijgt u "ja". Dus het volgende geeft allemaal "ja" terug:
=ALS(ISGETAL(ZOEK(12,A2)),"ja", "nee")
=ALS(ISGETAL(ZOEK(23,A2)),"ja", "nee")
=ALS(ISGETAL(ZOEK(3,A2)),"ja", "nee")

Ik heb geprobeerd de getallen tussen aanhalingstekens te plaatsen, maar zonder resultaat. De formule werkt perfect voor de use case van het voorbeeld, waarin alle getallen even lang zijn. Maar als u op zoek bent naar een korter getal dat toevallig in de tekenreeks voorkomt, krijgt u een vals positief.
Is er een alternatief voor "ZOEKEN" dat meer letterlijk is (alweer, is dat het woord? haha)? 
Bedankt! 
Deze opmerking is gemaakt door de moderator op de site
Hallo Scott S., bedoel je zoeken naar de exacte string?
Deze opmerking is gemaakt door de moderator op de site
Hallo, Kristal.
Ja, ik denk dat dat de manier is om het te formuleren. 
De huidige oplossing retourneert "Ja" voor elk deel van de cijferreeks. Dus de nummers 1, 2, 3, 12, 23 en 123 zullen allemaal "Ja" retourneren. 
Ik heb geprobeerd een oplossing te bedenken die een reeks getallen doorzoekt en "Ja" retourneert voor een exacte overeenkomst. 
Deze opmerking is gemaakt door de moderator op de site
Hallo Scott S, bedankt voor je feedback. Ik heb de oplossing nog niet gevonden en zal contact met je opnemen als ik het heb gevonden.
Deze opmerking is gemaakt door de moderator op de site
Hier heb ik een oplossing voor gevonden. Als u een komma links en rechts van uw lijst toevoegt en deze (zoals een sandwich) in uw zoekopdracht opneemt, kunt u een exacte overeenkomst vinden. Voorbeeld hieronder:
, 123,231,321,122,321,1,2,3,23,
ZOEKEN(",23,")
Op deze manier dwingt het de zoekopdracht om van de ene komma naar de andere te matchen in plaats van slechts een deel van het item uit de lijst. Hoop dat dit is wat je zocht?
Deze opmerking is gemaakt door de moderator op de site
Ik heb een oplossing gevonden. Als u een komma links en rechts van uw lijst toevoegt, heeft u de zoekfunctie nodig om een ​​exacte overeenkomst van komma tot komma te vinden. Zie voorbeeld hieronder:
=ALS(ISGETAL(ZOEK(",12,",A2)),"ja","nee")

, 312,123,10,112,126,
Dit retourneert false omdat er geen variabele van komma tot komma (,12,) is die overeenkomt met de zoekopdracht. 
Als je meer uitleg nodig hebt, laat het me dan weten en post een beter voorbeeld. Ik had hetzelfde probleem bij het automatiseren van een rapport voor mijn baas en had een openbaring. :)
Deze opmerking is gemaakt door de moderator op de site
Hallo, help alstublieft

Ik heb een tabel in Excel met twee kolommen A & B, onder A is er een waarde, bijvoorbeeld A2 Cell heeft 1,2,2,1,2,1,2 enz. (heeft slechts twee nummers 1 en 2, maar moet herkennen dat het alleen 1 & 2 in de hele cel en geen ander getal) en A3 heeft 1,1,1 en A4 heeft 0, A5 heeft 2,2,2,2 en A6 heeft 20. ik wil dat B2 de waarde voor A2 als Azië retourneert , B3 Afrika, B4 als Geen, B5 als Amerika en B6 als Europa. Ik dacht dat ik de if-formule kon gebruiken, maar het is niet in staat om door komma's gescheiden getallen te herkennen en de waarde terug te geven). Help alstublieft
Er zijn nog geen reacties geplaatst
Laat uw commentaar
Posten als gast
×
Beoordeel dit bericht:
0   Personages
Voorgestelde locaties